Skip to Content.
Sympa Menu

fr - Re: [sympa-fr] Probl�me de connexion LDAP

Subject: Pour les administrateurs de serveurs de listes utilisant le logiciel Sympa

List archive

Chronological Thread  
  • From: Matthieu Verove <address@concealed>
  • To: Serge <address@concealed>
  • Cc: address@concealed, address@concealed
  • Subject: Re: [sympa-fr] Problme de connexion LDAP
  • Date: Mon, 22 Nov 2004 11:11:14 +0100

Le ven 19/11/2004 à 20:16, Serge a écrit :
Bonjour
Salut,
C'est dans les logs :
Hum, je pense ne pas avoir été assez clair:

Je viens de tenter d'installer Sympa 4.1.2 avec une authentification par ldap et voici ce que j'ai dans les logs quand j'essaye de me connecter:
Nov 19 16:09:10 spafed03 wwsympa[23591]: [robot robot_name] [client XXX.XXX.XXX.XXX] do_login(mon_login)
Nov 19 16:09:10 spafed03 wwsympa[23591]: Auth::check_auth(mon_login)
Nov 19 16:09:10 spafed03 wwsympa[23591]: Auth::ldap_authentication(mon_login,mon_password)+,uid_filter)
Nov 19 16:09:10 spafed03 wwsympa[23591]: Unable to use LDAP library, Net::LDAP required, install perl-ldap (CPAN) first
or le module Net::LDAP est bien installé sur la machine. (moi aussi j'peux l'faire ;-))
Je sais que c'était vendredi mais j'avais déjà étudié cette piste là sinon je n'aurai pas posté sur la liste ;-)

En fait, on s'est aperçu que Sympa faisait appel à un .pm, Encode.pm pour être plus précis qui semble être fourni avec l'outil... MHonArc et, j'avoue, j'avais oublié de l'installer.
Mais je ne comprends pas bien pourquoi Sympa utilise ce .pm qui est fourni par MHonArc lors de la connexion des utilisateurs ?

A+
Matt



Archive powered by MHonArc 2.6.19+.

Top of Page