Skip to Content.
Sympa Menu

en - [sympa-users] Proposal - Full virtual domain support

Subject: The mailing list for listmasters using Sympa

List archive

Chronological Thread  
  • From: Scott Balmos <address@concealed>
  • To: address@concealed
  • Subject: [sympa-users] Proposal - Full virtual domain support
  • Date: Thu, 24 Feb 2005 01:11:19 -0500

I'll admit I'm looking at what Cef is suggesting. Though I'm already having to do that kind of a naming scheme in the background for Postfix to be happy. It ain't pretty. :)

You know what they say about Open Source... If you have an itch, scratch it. Attached is a proposed patch against 5.0b1 which implements full robot tracking in the database and (hopefully) all internal data structures, queue filenames, etc. See below for the summary list of changes. I have yet to really try this on my box... It passes a smoke test, as far as I can tell.

Comments, criticisms, etc greatly appreciated, especially if I missed anything (task_manager I'm worried about, for some reason). I had a few hours to kill, this problem was a showstopper for my system's setup, etc etc etc. I just hope I didn't royally screw anything and end up getting flamed off the list. :)

--Scott

subscriber_table
==
new varchar(100) field robot_subscriber after list_subscriber
added robot_subscriber to primary key & index

admin_table
==
new varchar(100) field robot_admin after list_admin
added robot_admin to primary key & index

updated $list_cache with new {$robot} dimension
old: if (defined $list_cache{'get_subscriber'}{$name}{$email}) {
new: if (defined $list_cache{'get_subscriber'}{$robot}{$name}{$email}) {

modified all queue file / task naming schemes. Instead of just the list name, they're now listname@robot (e.g. address@concealed for files stored by store_digest() in List.pm)

modified anonymous Message-ID headers, <list-robot.sequence@anonymous>

rewrote get_which_db. Returned hash is now of form $which->{robot}{list} = 1
rewrote get_lists. Now returns "list@robot" entries
rewrote get_which. Now returns "list@robot" entries
rewrote _load_total_db. Second parameter is robot name. E.g. _load_total_db($self->{'name'}, $self->{'domain'}, 'nocache')

Attachment: patches.tgz
Description: GNU Zip compressed data




Archive powered by MHonArc 2.6.19+.

Top of Page