Subject: Developers of Sympa
List archive
Re: [sympa-developpers] [sympa-commits] sympa[7924] branches/db_list_cache: [dev] References to global %Conf hash were replaced with Site class accessors.
- From: Guillaume Rousse <address@concealed>
- To: address@concealed
- Subject: Re: [sympa-developpers] [sympa-commits] sympa[7924] branches/db_list_cache: [dev] References to global %Conf hash were replaced with Site class accessors.
- Date: Fri, 09 Nov 2012 09:36:54 +0100
Le 08/11/2012 21:59, Guillaume Rousse a écrit :
I'd prefer an explicit method call, for better readability:
&mail::set_send_spool(Site->queue());
Actually, I've several similar code style preferences I'd like to propose, based on what is usually considered best practices in perl community. For instance:
- use direct method call syntax
My::Class->new()
- use modern perl idiom for heritage:
use parent qw(Parent::Class)
instead of legacy one:
use Parent::Class;
our @ISA = qw(Parent::Class)
- use full stricture everywhere:
use strict
- use modern perl function call syntax:
My::Package::function()
instead of legacy perl 4 syntax:
&My::Package::function()
- use block-based eval syntax:
eval {
require Foo::Bar;
};
instead of string-based syntax:
eval "require Foo::Bar;"
- use plain english name for magic variables:
use English qw(-no_match_vars)
print $UID
instead of:
print $<
Etc...
What is the best way to first discuss those preferences first, to enforce them in the code second ?
--
Guillaume Rousse
INRIA, Direction des systèmes d'information
Domaine de Voluceau
Rocquencourt - BP 105
78153 Le Chesnay
Tel: 01 39 63 58 31
Attachment:
smime.p7s
Description: Signature cryptographique S/MIME
-
Re: [sympa-developpers] [sympa-commits] sympa[7924] branches/db_list_cache: [dev] References to global %Conf hash were replaced with Site class accessors.,
Guillaume Rousse, 11/08/2012
-
Re: [sympa-developpers] [sympa-commits] sympa[7924] branches/db_list_cache: [dev] References to global %Conf hash were replaced with Site class accessors.,
Guillaume Rousse, 11/09/2012
-
Re: [sympa-developpers] [sympa-commits] sympa[7924] branches/db_list_cache: [dev] References to global %Conf hash were replaced with Site class accessors.,
IKEDA Soji, 11/09/2012
-
Re: [sympa-developpers] [sympa-commits] sympa[7924] branches/db_list_cache: [dev] References to global %Conf hash were replaced with Site class accessors.,
David Verdin, 11/12/2012
- Re: [sympa-developpers] [sympa-commits] sympa[7924] branches/db_list_cache: [dev] References to global %Conf hash were replaced with Site class accessors., Guillaume Rousse, 11/12/2012
-
Re: [sympa-developpers] [sympa-commits] sympa[7924] branches/db_list_cache: [dev] References to global %Conf hash were replaced with Site class accessors.,
David Verdin, 11/12/2012
-
Re: [sympa-developpers] [sympa-commits] sympa[7924] branches/db_list_cache: [dev] References to global %Conf hash were replaced with Site class accessors.,
IKEDA Soji, 11/09/2012
-
Re: [sympa-developpers] [sympa-commits] sympa[7924] branches/db_list_cache: [dev] References to global %Conf hash were replaced with Site class accessors.,
Guillaume Rousse, 11/09/2012
Archive powered by MHonArc 2.6.19+.