Skip to Content.
Sympa Menu

fr - Re: [sympa-fr] Pb de mise à jour des abonnés via une source de données en ldaps

Subject: Pour les administrateurs de serveurs de listes utilisant le logiciel Sympa

List archive

Chronological Thread  
  • From: "Marianne BALANCHE (CRI)" <address@concealed>
  • To: Benoit Branciard <address@concealed>, address@concealed
  • Subject: Re: [sympa-fr] Pb de mise à jour des abonnés via une source de données en ldaps
  • Date: Thu, 2 May 2019 11:04:44 +0200

Bonjour,

Merci pour ce patch. Je vais tester cela.

Pour l'instant j'ai testé une migration sous debian et ça fonctionne après avoir changé la version de ssl dans la config des listes (de la v3 à la tls1_2) après la migration.
Sous CentOS 7 j'ai testé en modifiant la version de ssl dans la config de 2 listes avant la migration et ça a fonctionné. Mais quand je fais la même chose pour la totalité des listes ça ne fonctionne plus.
Donc votre patch peut peut-être réglé ce problème.

Encore merci et je vous tiens informé.

Cordialement

Le 19/04/2019 à 18:59, Benoit Branciard a écrit :
Bonjour,

nous avons patché le fichier list.pm.
Ci-joint le patch à appliquer sur l'arborescence source avant installation (make / make install).

Ce patch est pour la version 6.1.25 de Sympa, sur un Debian 9 (OpenSSL 1.0.1t, libio-socket-ssl-perl 1.76-2).

Je n'ai pas vérifié si ce problème de libellé de ssl_version se présente de la même façon en Sympa 6.2, ni avec une autre variante de Linux (CentOS, etc). En tout cas nous on l'a depuis pas mal de temps sous Debian (au moins depuis Debian 6 !).

Pour info avant de faire le "grand saut" en Sympa 6.2 on a poussé à bout notre 6.1, en y ajoutant plusieurs patches pour combler ses lacunes (notamment la gestion du DMARC); mais c'est un autre pb.

Le 01/04/2019 à 17:27, Marianne BALANCHE (CRI) a écrit :
Ça peut peut-être  aider.
Vous avez patché quel fichier source de Sympa ?

Merci

Le 29/03/2019 à 11:30, Benoit Branciard a écrit :
Si ça peut aider:

sur notre config Sympa qui est basée sur du Debian (Debian 7 précédemment, 9 maintenant), la bibliothèque LDAP/TLS utilisée par Sympa (à priori c'est Net::LDAP qui s'appuie sur OpenSSL) n'*accepte pas* les options de version TLS (ssl_version) telle qu'elles sont formulées par Sympa:  tlsv1_1 et tlsv1_2.

J'ai dû patcher le source de Sympa (6.1) pour lui faire envoyer la syntaxe attendue par la bibliothèque, à savoir: tlsv11 et tlsv12 (sans le "_").

Je ne sais pas si cette syntaxe est spécifique à Debian, j'imagine que oui sinon le pb aurait été plus souvent remonté...

Quoi qu'il en soit, l'idéal serait de ne PAS avoir à spécifier cette option, et de laisser le client (Sympa) négocier avec le serveur (LDAP) la version de protocole la plus élevée qu'ils ont en commun; mais l'IHM de Sympa ne permet pas de laisser ce paramètre vide.


Le 29/03/2019 à 09:57, Marianne BALANCHE (CRI) a écrit :
Bonjour,

Le but est de transférer notre vieux serveur de listes en 5.4.7 sur une dernière version de sympa plus à jour à tous les niveaux (fonctionnalités, sécurité, ...).

Notre serveur LDAP répond à la version TLS 1.2.
J'ai testé en mettant TLS v1_2 (j'ai testé aussi toutes les autres versions) mais j'obtiens exactement le même message d'erreur mais avec la version ssl différente :
ssl_ciphers=ALL;ssl_version=tlsv1_2;use_tls=ldaps
Mais on ne voit aucune connexion sur le serveur LDAP quand on utilise le protocole ldaps via sympa alors que ça fonctionne en faisant un ldapsearch en 636.






--
+-------------------------------------------------------------------+
Marianne BALANCHE
Centre de Ressources Informatiques
Université de Franche-Comté
16, route de Gray
25030 Besançon Cedex - FRANCE
Tél. : 03 81 66 61 19 Fax : 03 81 66 61 77
Mél : address@concealed
+-------------------------------------------------------------------+



  • Re: [sympa-fr] Pb de mise à jour des abonnés via une source de données en ldaps, Marianne BALANCHE (CRI), 05/02/2019

Archive powered by MHonArc 2.6.19+.

Top of Page